blob: 553e22b393fcf06443ddfe4b4bfbea779e748c5c [file] [log] [blame]
{
description = "The Chimera nix configuration flake, a shared system configuration";
inputs = {
anyrun = {
url = "github:Kirottu/anyrun";
inputs.nixpkgs.follows = "nixpkgs";
};
ewwsalmoomedits--eww-widgets = {
url = "github:saimoomedits/eww-widgets";
flake = false;
};
home-manager = {
url = "github:nix-community/home-manager";
inputs.nixpkgs.follows = "nixpkgs";
};
hyprland.url = "github:hyprwm/Hyprland";
nix-index-database = {
url = "github:nix-community/nix-index-database";
inputs.nixpkgs.follows = "nixpkgs";
};
nixpkgs.url = "github:nixos/nixpkgs/nixos-unstable";
nur.url = "github:nix-community/nur";
snowfall-lib = {
url = "github:snowfallorg/lib";
inputs.nixpkgs.follows = "nixpkgs";
};
sops-nix.url = "github:Mic92/sops-nix";
templates.url = "git+https://git.clicks.codes/Templates";
};
outputs =
{ self, nixpkgs, ... }@inputs:
let
extraHomeModules = [
inputs.anyrun.homeManagerModules.default
inputs.hyprland.homeManagerModules.default
inputs.nur.hmModules.nur
inputs.nix-index-database.hmModules.nix-index
];
in
inputs.snowfall-lib.mkFlake {
inherit inputs;
src = ./.;
homes.users."coded@shorthair".modules = extraHomeModules;
homes.users."minion@greylag".modules = extraHomeModules;
systems.modules.nixos = [
inputs.hyprland.nixosModules.default
inputs.nur.nixosModules.nur
inputs.sops-nix.nixosModules.sops
];
snowfall = {
namespace = "chimera";
meta.name = "chimera";
meta.title = "Coded and Minion's Nix Configurations";
};
outputs-builder = channels: {
formatter = nixpkgs.legacyPackages.${channels.nixpkgs.system}.nixfmt-rfc-style;
};
channels-config = {
allowUnfree = true;
};
};
}