| {...}: { |
| services.pipewire.extraConfig.pipewire."new-virtual-devices" = { |
| "context.modules" = [ |
| { |
| name = "libpipewire-module-combine-stream"; |
| args = { |
| "combine.mode" = "sink"; |
| "node.name" = "output"; |
| "node.description" = "Combined Outputs"; |
| "combine.latency-compensate" = false; |
| "combine.props" = { |
| "audio.position" = [ "FL" "FR" ]; |
| }; |
| "stream.props" = { |
| "stream.dont-remix" = true; |
| }; |
| "stream.rules" = [ |
| { |
| matches = [ |
| { |
| "media.class" = "Audio/Sink"; |
| "node.name" = "alsa_output.usb-NXP_SEMICONDUCTORS_Razer_Kraken_V3_Pro-00.analog-stereo"; |
| } |
| { |
| "media.class" = "Audio/Sink"; |
| "node.name" = "alsa_output.usb-R__DE_RODECaster_Duo_IR0023015-00.analog-stereo"; |
| } |
| ]; |
| actions = { |
| create-stream = { |
| "audio.position" = [ "FL" "FR" ]; |
| "combine.audio.position" = [ "FL" "FR" ]; |
| }; |
| }; |
| } |
| ]; |
| }; |
| } |
| ]; |
| }; |
| } |