| theme.wallpaper = lib.mkOption { |
| description = "Wallpaper of your choosing"; |
| hyprland.hyprpaper.splash = { |
| enable = lib.mkEnableOption "Enable the hyprland splash text"; |
| description = "Set the splash offset"; |
| config.xdg.configFile = lib.mkIf config.chimera.hyprland.enable { |
| "hypr/hyprpaper.conf".source = ( |
| builtins.toFile "hyprpaper.conf" '' |
| preload = ${config.chimera.theme.wallpaper} |
| wallpaper=,${config.chimera.theme.wallpaper} |
| splash = ${if config.chimera.hyprland.hyprpaper.splash.enable then "true" else "false"} |
| splash_offset = ${builtins.toString config.chimera.hyprland.hyprpaper.splash.offset} |