greylag: Add framework tweaks and firmware support

Change-Id: I5932f5b413b9b599c6556a3e01878d8daed3f320
Reviewed-on: https://git.clicks.codes/c/Chimera/NixFiles/+/436
Tested-by: Skyler Grey <minion@clicks.codes>
Reviewed-by: Skyler Grey <minion@clicks.codes>
diff --git a/flake.nix b/flake.nix
index 553e22b..c9de99c 100644
--- a/flake.nix
+++ b/flake.nix
@@ -24,6 +24,8 @@
       inputs.nixpkgs.follows = "nixpkgs";
     };
 
+    nixos-hardware.url = "github:nixos/nixos-hardware/master";
+
     nixpkgs.url = "github:nixos/nixpkgs/nixos-unstable";
 
     nur.url = "github:nix-community/nur";
@@ -62,6 +64,10 @@
         inputs.sops-nix.nixosModules.sops
       ];
 
+      systems.hosts.greylag.modules = [
+        inputs.nixos-hardware.nixosModules.framework-13th-gen-intel
+      ];
+
       snowfall = {
         namespace = "chimera";