blob: 475c0a93d2145a958d1f59e92ff13c86347b186f [file] [log] [blame]
{
config,
lib,
pkgs,
...
}:
{
options.chimera.gpg = {
enable = lib.mkEnableOption "Enable gpg";
};
config = lib.mkIf config.chimera.gpg.enable {
programs.gpg.enable = true;
services.gpg-agent = {
enable = true;
pinentryFlavor = "tty";
enableZshIntegration = config.chimera.shell.zsh.enable;
enableBashIntegration = config.chimera.shell.bash.enable;
};
};
}