blob: d5dadd5413b6a380919875ac4ee85063af007930 [file] [log] [blame]
{
config,
lib,
pkgs,
...
}:
{
options.chimera.gpg = {
enable = lib.mkEnableOption "Enable gpg";
};
config = lib.mkIf config.chimera.gpg.enable {
programs.gpg = {
enable = true;
scdaemonSettings = lib.mkIf config.chimera.yubikey.enable {
reader-port = "Yubico Yubi";
disable-ccid = true;
};
};
services.gpg-agent = {
enable = true;
pinentryPackage = pkgs.pinentry-gtk2;
enableZshIntegration = config.chimera.shell.zsh.enable;
enableBashIntegration = config.chimera.shell.bash.enable;
};
};
}