blob: c471fcbea8cdd0a0adff057c14c3419da87fce42 [file] [log] [blame]
{ lib, config, ... }:
{
options.chimera.touchpad.enable = lib.mkEnableOption "Enable touchpad gestures";
config = lib.mkIf (config.chimera.touchpad.enable && config.chimera.hyprland.enable) {
services.fusuma.enable = true;
systemd.user.startServices = "sd-switch";
systemd.user.services.fusuma.Unit.X-Restart-Triggers = [
config.xdg.configFile."fusuma/config.yml".source
];
};
}