blob: 70983658b881bfcfdf83dfd8ec6652c332119d31 [file] [log] [blame]
Samuel Shuert02ffd1e2024-02-13 21:37:15 -05001{ config, lib, ... }:
2{
3 options.chimera.editor.neovim = {
4 enable = lib.mkEnableOption "Enable neovim editor";
5 defaultEditor = lib.mkOption {
6 type = lib.types.bool;
7 description = "Use neovim as the default editor";
8 default = true;
9 };
10 };
11
12 config = lib.mkIf config.chimera.editor.neovim.enable {
13 programs.neovim = {
14 enable = true;
15 defaultEditor = config.chimera.editor.neovim.defaultEditor;
16 };
17 };
18}