blob: 3eb3bf6592eaec182807e60943daa04fac81b6c5 [file] [log] [blame]
Samuel Shuert02ffd1e2024-02-13 21:37:15 -05001{ config, lib, ... }:
2{
3 options.chimera.shell.bash = {
4 enable = lib.mkEnableOption "Enable Bash Shell";
5 default = lib.mkOption {
6 type = lib.types.bool;
7 description = "Set as default shell";
8 default = true;
9 };
10 extraAliases = lib.mkOption {
11 type = lib.types.attrsOf lib.types.str;
12 description = "Attrset of extra shell aliases";
13 default = { };
14 };
15 };
16
17 config = lib.mkIf config.chimera.shell.bash.enable {
18 programs.bash = {
19 enable = true;
20
21 shellAliases = config.chimera.shell.bash.extraAliases;
22 };
23 };
24}