blob: f17ef2f51507dab7c2ab930a07069fc600ca8602 [file] [log] [blame]
Skyler Grey695fa632024-02-17 22:45:41 +00001{
2 config,
3 lib,
4 pkgs,
5 ...
6}:
7{
8 options.chimera.gpg = {
9 enable = lib.mkEnableOption "Enable gpg";
10 };
11
12 config = lib.mkIf config.chimera.gpg.enable {
13 programs.gpg.enable = true;
14 services.gpg-agent = {
15 enable = true;
16 pinentryFlavor = "curses";
17 enableZshIntegration = config.chimera.shell.zsh.enable;
18 enableBashIntegration = config.chimera.shell.bash.enable;
19 };
20 };
21}