blob: 27d149a5db1b333cb9f14f20aa591359895f95d3 [file] [log] [blame]
Skyler Grey4e230892024-02-13 22:58:46 +00001{ config, lib, ... }:
2{
3 options.chimera = {
4 wallpaper = lib.mkOption {
5 type = lib.types.path;
6 description = "Wallpaper of your choosing";
7 };
8 hyprland.hyprpaper.splash = {
9 enable = lib.mkEnableOption "Enable the hyprland splash text";
10 offset = lib.mkOption {
11 type = lib.types.float;
12 description = "Set the splash offset";
13 default = 2.0;
14 };
15 };
16 };
Skyler Greya0da6b22024-02-11 22:53:41 +000017
Skyler Grey4e230892024-02-13 22:58:46 +000018 # TODO: wallpapers path[] -> gen wallpaper lines...
19 config.xdg.configFile."hypr/hyprpaper.conf".source = lib.mkIf config.chimera.hyprland.enable (
20 builtins.toFile "hyprpaper.conf" ''
21 preload = ${config.chimera.wallpaper}
Skyler Greya0da6b22024-02-11 22:53:41 +000022
Skyler Grey4e230892024-02-13 22:58:46 +000023 wallpaper=,${config.chimera.wallpaper}
24
25 splash = ${builtins.toString config.chimera.hyprland.hyprpaper.splash.enable}
26 splash_offset = ${builtins.toString config.chimera.hyprland.hyprpaper.splash.offset}
27
28 ipc = off
29 ''
30 );
Skyler Greya0da6b22024-02-11 22:53:41 +000031}