blob: 61b0ecbff4b976682a4d234237f4305a5d15dac8 [file] [log] [blame]
Skyler Grey4e230892024-02-13 22:58:46 +00001{
2 config,
3 lib,
4 pkgs,
5 modulesPath,
6 ...
7}:
8
9{
10 imports = [ (modulesPath + "/installer/scan/not-detected.nix") ];
11
12 boot.initrd.availableKernelModules = [
13 "nvme"
14 "xhci_pci"
15 "ahci"
16 "usb_storage"
17 "usbhid"
18 "sd_mod"
19 "sr_mod"
20 ];
21 boot.initrd.kernelModules = [ "amdgpu" ];
22 boot.kernelModules = [ ];
23 boot.extraModulePackages = [ ];
24
25 boot.initrd = {
26 luks.devices."luks-bf23eee1-7cb7-43b9-822f-a9f49ea0a768".device =
27 "/dev/disk/by-uuid/bf23eee1-7cb7-43b9-822f-a9f49ea0a768";
28 luks.devices."luks-c38bc921-8979-4a25-9520-f3354dee3557".device =
29 "/dev/disk/by-uuid/c38bc921-8979-4a25-9520-f3354dee3557";
30 };
31
32 fileSystems."/" = {
33 device = "/dev/disk/by-uuid/63caf2b5-90d4-49a7-99e9-98dcdd797859";
34 fsType = "ext4";
35 };
36
37 fileSystems."/boot" = {
38 device = "/dev/disk/by-uuid/5B78-4B2D";
39 fsType = "vfat";
40 };
41
42 swapDevices = [ { device = "/dev/disk/by-uuid/3a9212d4-6c39-4d5b-abf0-49294bd991c9"; } ];
43
44 networking.useDHCP = lib.mkDefault true;
45
46 nixpkgs.hostPlatform = lib.mkDefault "x86_64-linux";
47 hardware.cpu.amd.updateMicrocode = lib.mkDefault config.hardware.enableRedistributableFirmware;
48}