blob: ccfd1f12527c8985a6fb45f9db325ea5593b9e84 [file] [log] [blame]
Skyler Greya0da6b22024-02-11 22:53:41 +00001{
Skyler Grey4e230892024-02-13 22:58:46 +00002 # Snowfall Lib provides a customized `lib` instance with access to your flake's library
3 # as well as the libraries available from your flake's inputs.
4 lib,
5 # An instance of `pkgs` with your overlays and packages applied is also available.
6 pkgs,
7 # You also have access to your flake's inputs.
8 inputs,
Skyler Greya0da6b22024-02-11 22:53:41 +00009
Skyler Grey4e230892024-02-13 22:58:46 +000010 # Additional metadata is provided by Snowfall Lib.
11 home, # The home architecture for this host (eg. `x86_64-linux`).
12 target, # The Snowfall Lib target for this home (eg. `x86_64-home`).
13 format, # A normalized name for the home target (eg. `home`).
14 virtual, # A boolean to determine whether this home is a virtual target using nixos-generators.
15 host, # The host name for this home.
Skyler Greya0da6b22024-02-11 22:53:41 +000016
Skyler Grey4e230892024-02-13 22:58:46 +000017 # All other arguments come from the home home.
18 config,
19 ...
Skyler Greya0da6b22024-02-11 22:53:41 +000020}:
21{
Skyler Grey57f6b782024-03-13 14:43:09 +000022 home.packages = [
23 pkgs.home-manager
24 pkgs.chimera.gtimelog-collabora
25 ];
Skyler Greya2c02ac2024-03-01 21:10:17 +000026 chimera.minion.enable = true;
27
28 home.shellAliases.home-manager = "${pkgs.home-manager}/bin/home-manager --flake ${config.chimera.shell.rebuildFlakePath}#skyler@canvasback";
29
Skyler Grey57f6b782024-03-13 14:43:09 +000030 sops.gnupg.home = config.programs.gpg.homedir;
31 sops.secrets."homes/x86_64-linux/skyler@canvasback/gtimelogrc.sops.minion.toml.bin" = {
32 format = "binary";
33 sopsFile = ./gtimelogrc.sops.minion.toml.bin;
34 path = "${config.home.homeDirectory}/.gtimelog/gtimelogrc";
35 };
36
Skyler Greya2c02ac2024-03-01 21:10:17 +000037 programs.kitty.settings.shell = "${pkgs.bashInteractive}/bin/bash --login"; # nasty hack to make environment variables load on gnome
Skyler Greya0da6b22024-02-11 22:53:41 +000038}