Samuel Shuert | 004d075 | 2024-03-02 11:57:09 -0500 | [diff] [blame] | 1 | { |
| 2 | inputs, |
| 3 | pkgs, |
| 4 | system, |
| 5 | lib, |
| 6 | config, |
| 7 | ... |
| 8 | }: |
| 9 | { |
| 10 | options.chimera.runner.anyrun = { |
| 11 | enable = lib.mkOption { |
| 12 | type = lib.types.bool; |
| 13 | default = true; |
| 14 | description = "Whether or not to enable the anyrun runner"; |
| 15 | }; |
| 16 | }; |
| 17 | |
| 18 | config = { |
| 19 | chimera.runner.enable = lib.mkIf config.chimera.runner.anyrun.enable true; |
| 20 | |
| 21 | programs.anyrun = { |
| 22 | enable = true; |
| 23 | config = { |
| 24 | plugins = [ |
| 25 | inputs.anyrun.packages.${system}.applications |
| 26 | inputs.anyrun.packages.${system}.rink |
| 27 | inputs.anyrun.packages.${system}.shell |
| 28 | inputs.anyrun.packages.${system}.translate |
| 29 | inputs.anyrun.packages.${system}.kidex |
| 30 | inputs.anyrun.packages.${system}.symbols |
| 31 | ]; |
| 32 | |
| 33 | # Styling as it's top level for some reason |
| 34 | x = { fraction = 0.5; }; |
| 35 | y = { fraction = 0.3; }; |
| 36 | width = { fraction = 0.3; }; |
| 37 | closeOnClick = true; |
| 38 | |
| 39 | }; |
| 40 | extraCss = '' |
| 41 | #window { |
| 42 | background-color: transparent; |
| 43 | } |
| 44 | #main * { |
| 45 | background-color: #${config.chimera.theme.colors.Surface0.hex}; |
| 46 | color: #${config.chimera.theme.colors.Text.hex}; |
| 47 | caret-color: alpha(#${config.chimera.theme.colors.Accent.hex},0.6); |
| 48 | font-family: ${config.chimera.theme.font.variableWidth.sansSerif.name}; |
| 49 | } |
| 50 | #main { |
| 51 | border-width: 1px; |
| 52 | border-style: solid; |
| 53 | border-color: #${config.chimera.theme.colors.Accent.hex}; |
| 54 | border-radius: 5px; |
| 55 | } |
| 56 | #main #main { |
| 57 | border-style: none; |
| 58 | border-bottom-left-radius: 5px; |
| 59 | border-bottom-right-radius: 5px; |
| 60 | } |
| 61 | #match-title, #match-desc { |
| 62 | font-family: ${config.chimera.theme.font.variableWidth.sansSerif.name}; |
| 63 | } |
| 64 | #entry { |
| 65 | min-height: 36px; |
| 66 | padding: 10px; |
| 67 | font-size: 24px; |
| 68 | box-shadow: none; |
| 69 | border-style: none; |
| 70 | } |
| 71 | #entry:focus { |
| 72 | box-shadow: none; |
| 73 | } |
| 74 | #entry selection { |
| 75 | background-color: alpha(#${config.chimera.theme.colors.Yellow.hex},0.3); |
| 76 | color: transparent; |
| 77 | } |
| 78 | ''; |
| 79 | }; |
| 80 | }; |
| 81 | } |