blob: 57a454899a3099ee7a5091298120cd4a1eb3d08e [file] [log] [blame]
Samuel Shuert02ffd1e2024-02-13 21:37:15 -05001{
2 config,
3 lib,
4 pkgs,
5 ...
6}:
7{
8 options.chimera.terminal.kitty = {
9 enable = lib.mkOption {
10 type = lib.types.bool;
11 description = "Use kitty as your terminal";
12 default = true;
13 };
14 };
15
16 config = lib.mkIf config.chimera.terminal.kitty.enable {
Skyler Grey5ee9c3b2024-03-01 21:50:12 +000017 home.shellAliases = {
18 ssh = "${config.programs.kitty.package}/bin/kitten ssh";
19 };
20
Samuel Shuert02ffd1e2024-02-13 21:37:15 -050021 programs.kitty = {
22 enable = true;
23 theme =
24 if config.chimera.theme.catppuccin.enable then
25 "Catppuccin-${config.chimera.theme.catppuccin.style}"
26 else
27 null;
28 font = config.chimera.theme.font.mono;
29 shellIntegration = {
30 enableZshIntegration = config.chimera.shell.zsh.enable;
31 enableBashIntegration = config.chimera.shell.bash.enable;
32 };
33 settings = {
34 confirm_os_window_close = -1;
35 symbol_map = lib.mkIf config.chimera.theme.font.nerdFontGlyphs.enable "U+23FB-U+23FE,U+2665,U+26A1,U+2B58,U+E000-U+E00A,U+E0A0-U+E0A3,U+E0B0-U+E0D4,U+E200-U+E2A9,U+E300-U+E3E3,U+E5FA-U+E6AA,U+E700-U+E7C5,U+EA60-U+EBEB,U+F000-U+F2E0,U+F300-U+F32F,U+F400-U+F4A9,U+F500-U+F8FF,U+F0001-U+F1AF0 Symbols Nerd Font Mono";
36 };
37 };
38 };
39}