Samuel Shuert | 2e42e67 | 2024-02-21 21:49:28 +0000 | [diff] [blame] | 1 | nixpkgs: let |
| 2 | keys = { |
| 3 | users = { |
| 4 | coded = "BC82DF237610AE9113EB075900E944BFBE99ADB5"; |
| 5 | minion = "76E0B09A741C4089522111E5F27E3E5922772E7A"; |
| 6 | }; |
| 7 | hosts = { |
| 8 | shorthair = "B5237D6B63AB2E13FDA07170E5AED9775DD21543"; |
| 9 | greylag = "047bf8897df877fe86133e98522c6d280d545c00"; |
| 10 | }; |
| 11 | }; |
| 12 | in { |
| 13 | creation_rules = [ |
| 14 | { |
| 15 | path_regex = ''.*\.sops\.chimera\.(yaml|json|env|ini|[^.]*\.bin)$''; |
| 16 | pgp = nixpkgs.lib.concatStringsSep "," [ |
| 17 | keys.users.coded |
| 18 | keys.users.minion |
| 19 | keys.hosts.shorthair |
| 20 | keys.hosts.greylag |
| 21 | ]; |
| 22 | } |
| 23 | { |
| 24 | path_regex = ''.*\.sops\.coded\.(yaml|json|env|ini|[^.]*\.bin)$''; |
| 25 | pgp = nixpkgs.lib.concatStringsSep "," [ |
| 26 | keys.users.coded |
| 27 | keys.hosts.shorthair |
| 28 | ]; |
| 29 | } |
| 30 | { |
| 31 | path_regex = ''.*\.sops\.minion\.(yaml|json|env|ini|[^.]*\.bin)$''; |
| 32 | pgp = nixpkgs.lib.concatStringsSep "," [ |
| 33 | keys.users.minion |
| 34 | keys.hosts.greylag |
| 35 | ]; |
| 36 | } |
| 37 | ]; |
| 38 | } |