Skyler Grey | 695fa63 | 2024-02-17 22:45:41 +0000 | [diff] [blame] | 1 | { |
| 2 | config, |
| 3 | lib, |
| 4 | pkgs, |
| 5 | ... |
| 6 | }: |
| 7 | { |
| 8 | options.chimera.gpg = { |
| 9 | enable = lib.mkEnableOption "Enable gpg"; |
| 10 | }; |
| 11 | |
| 12 | config = lib.mkIf config.chimera.gpg.enable { |
| 13 | programs.gpg.enable = true; |
| 14 | services.gpg-agent = { |
| 15 | enable = true; |
Samuel Shuert | b3c6ca7 | 2024-02-20 22:51:42 +0000 | [diff] [blame] | 16 | pinentryFlavor = "tty"; |
Skyler Grey | 695fa63 | 2024-02-17 22:45:41 +0000 | [diff] [blame] | 17 | enableZshIntegration = config.chimera.shell.zsh.enable; |
| 18 | enableBashIntegration = config.chimera.shell.bash.enable; |
| 19 | }; |
| 20 | }; |
Samuel Shuert | 659b564 | 2024-02-23 20:47:43 +0000 | [diff] [blame] | 21 | } |