blob: afc5748d130c5747396fb63d66c7f5e8b98d33c9 [file] [log] [blame]
Skyler Greya0da6b22024-02-11 22:53:41 +00001{
2 description = "All my Nix configurations";
3
4 inputs = {
5 nixpkgs.url = "github:nixos/nixpkgs/nixos-unstable";
6
7 snowfall-lib = {
8 url = "github:snowfallorg/lib";
9 inputs.nixpkgs.follows = "nixpkgs";
10 };
11
12 home-manager = {
13 url = "github:nix-community/home-manager";
14 inputs.nixpkgs.follows = "nixpkgs";
15 };
16
17 nix-index-database = {
18 url = "github:nix-community/nix-index-database";
19 inputs.nixpkgs.follows = "nixpkgs";
20 };
21
22 hyprland.url = "github:hyprwm/Hyprland";
23
24 anyrun = {
25 url = "github:Kirottu/anyrun";
26 inputs.nixpkgs.follows = "nixpkgs";
27 };
28
29 ewwsalmoomedits--eww-widgets = {
30 url = "github:saimoomedits/eww-widgets";
31 flake = false;
32 };
33 };
34
35 outputs = { self, nixpkgs, ... }@inputs:
36 inputs.snowfall-lib.mkFlake {
37 inherit inputs;
38 src = ./.;
39
40 homes.modules = [
41 # TODO: inputs.nix-index-database.hmModules.nix-index
42 ];
43
44 homes.users."minion@greylag".modules = [
45 inputs.hyprland.homeManagerModules.default
46 inputs.anyrun.homeManagerModules.default
47 ];
48
49 system.modules.nixos = [
50 inputs.hyprland.nixosModules.default
51 ];
52
53 snowfall = {
54 namespace = "minion";
55
56 meta.name = "minion";
57 meta.title = "Minion's Nix Configurations";
58 };
59
60 outputs-builder = channels: {
61 formatter = nixpkgs.legacyPackages.${channels.nixpkgs.system}.nixfmt;
62 };
63
64 channels-config = {
65 allowUnfree = true;
66 };
67 };
68}