blob: 187ea5111501ed18bd98323492bde9dec4cd1884 [file] [log] [blame]
Skyler Grey4e230892024-02-13 22:58:46 +00001{
2 # Snowfall Lib provides a customized `lib` instance with access to your flake's library
3 # as well as the libraries available from your flake's inputs.
4 lib,
5 # An instance of `pkgs` with your overlays and packages applied is also available.
6 pkgs,
7 # You also have access to your flake's inputs.
8 inputs,
9
10 # Additional metadata is provided by Snowfall Lib.
11 home, # The home architecture for this host (eg. `x86_64-linux`).
12 target, # The Snowfall Lib target for this home (eg. `x86_64-home`).
13 format, # A normalized name for the home target (eg. `home`).
14 virtual, # A boolean to determine whether this home is a virtual target using nixos-generators.
15 host, # The host name for this home.
16
17 # All other arguments come from the home home.
18 config,
19 ...
20}:
21{
Samuel Shuertcc979af2024-06-20 21:07:22 -040022 chimera.users.coded.enable = true;
Samuel Shuert6d47eef2024-05-25 14:01:31 -040023
Samuel Shuertcc979af2024-06-20 21:07:22 -040024 chimera.waybar.modules.temperature.hwmonPath = "/sys/class/hwmon/hwmon4/temp1_input";
Samuel Shuert6d47eef2024-05-25 14:01:31 -040025
Samuel Shuertcc979af2024-06-20 21:07:22 -040026 chimera.niri = {
27 enable = true;
Samuel Shuertdab963e2024-03-23 19:54:28 -040028
Samuel Shuertcc979af2024-06-20 21:07:22 -040029 monitors = {
30 "DP-1" = {
31 mode = {
32 width = 1920;
33 height = 1080;
34 refresh = 165.;
35 };
36 position = {
37 x = 0;
38 y = 0;
39 };
Skyler Grey4cd2e0a2024-02-15 19:59:19 +000040 };
Samuel Shuertcc979af2024-06-20 21:07:22 -040041 "DP-2" = {
42 mode = {
43 width = 1920;
44 height = 1080;
45 refresh = 165.;
Samuel Shuert4d5c5fb2024-06-09 09:39:11 -040046 };
Samuel Shuertcc979af2024-06-20 21:07:22 -040047 position = {
48 x = 1920;
49 y = 0;
Samuel Shuert4d5c5fb2024-06-09 09:39:11 -040050 };
Samuel Shuertcc979af2024-06-20 21:07:22 -040051 };
52 "HDMI-A-1" = {
53 mode = {
54 width = 3840;
55 height = 2160;
56 refresh = 60.;
57 };
58 position = {
59 x = 0;
60 y = -2160;
Samuel Shuert4d5c5fb2024-06-09 09:39:11 -040061 };
Skyler Grey4e230892024-02-13 22:58:46 +000062 };
63 };
Skyler Grey4e230892024-02-13 22:58:46 +000064 };
Samuel Shuert30eebdf2024-02-29 17:26:35 -050065
Samuel Shuertcc979af2024-06-20 21:07:22 -040066 chimera.theme.wallpaper = ./wallpaper.png;
Samuel Shuert6cc9e6d2024-03-01 17:14:04 -050067
Samuel Shuertcc979af2024-06-20 21:07:22 -040068 # SSH Config
69 programs.ssh = {
70 enable = true;
Samuel Shuert30eebdf2024-02-29 17:26:35 -050071
Samuel Shuertcc979af2024-06-20 21:07:22 -040072 includes = [ "~/.ssh/config.d/*" ];
73
74 matchBlocks = {
Samuel Shuertcc979af2024-06-20 21:07:22 -040075 "github.com" = {
76 user = "git";
Samuel Shuert61647a92024-06-29 14:17:21 -040077 identityFile = [ "~/.ssh/ShorthairNanoResident" "~/.ssh/OnTheGo5cResident" ];
Samuel Shuertcc979af2024-06-20 21:07:22 -040078 };
Samuel Shuert61647a92024-06-29 14:17:21 -040079 "greylag.minion" = {
80 identityFile = [ "~/.ssh/ShorthairNanoResident" "~/.ssh/OnTheGo5cResident" ];
81 };
82 "ocicat" = {
83 identityFile = [ "~/.ssh/ShorthairNanoResident" "~/.ssh/OnTheGo5cResident" ];
84 };
85 "git.auxolotl.org" = {
86 user = "forgejo";
87 identityFile = [ "~/.ssh/ShorthairNanoResident" "~/.ssh/OnTheGo5cResident" ];
Samuel Shuertedbbcc32024-06-27 15:36:45 -040088 };
Samuel Shuert30eebdf2024-02-29 17:26:35 -050089 };
Samuel Shuertcc979af2024-06-20 21:07:22 -040090 };
Skyler Grey4e230892024-02-13 22:58:46 +000091}