Skyler Grey | 0ca833d | 2024-03-03 13:05:10 +0000 | [diff] [blame] | 1 | { config, lib, pkgs, ... }: { |
2 | options = { | ||||
3 | chimera.xdg-open.enable = lib.mkOption { | ||||
4 | type = lib.types.bool; | ||||
5 | description = "Whether to enable xdg-open"; | ||||
6 | default = false; | ||||
7 | example = true; | ||||
8 | }; | ||||
9 | }; | ||||
10 | |||||
11 | config = lib.mkIf config.chimera.xdg-open.enable { | ||||
12 | xdg.portal.enable = true; | ||||
13 | xdg.portal.xdgOpenUsePortal = true; | ||||
14 | environment.systemPackages = [ pkgs.xdg-utils ]; | ||||
15 | }; | ||||
16 | } |