blob: b0dd6f0019e809ef4e83117a091894c480ed8fd7 [file] [log] [blame]
Samuel Shuertfc05cfb2024-03-23 21:37:08 -04001{ config, lib, pkgs, ... }: {
2 options.chimera.nextcloud.enable = lib.mkEnableOption "Enable Nextcloud Client";
3 config = {
4 services.nextcloud-client = lib.mkIf config.chimera.nextcloud.enable {
5 enable = true;
6 startInBackground = true;
7 };
8 home.packages = [ pkgs.nextcloud-client ];
9 };
10}