blob: 40e6d12c6ba456f9e2f7b5c304e502d3081bbdfd [file] [log] [blame]
PineaFanfd2f8242024-04-20 20:51:36 +01001{
2 # Snowfall Lib provides a customized `lib` instance with access to your flake's library
3 # as well as the libraries available from your flake's inputs.
4 lib,
5 # An instance of `pkgs` with your overlays and packages applied is also available.
6 pkgs,
7 # You also have access to your flake's inputs.
8 inputs,
9
10 # Additional metadata is provided by Snowfall Lib.
11 home, # The home architecture for this host (eg. `x86_64-linux`).
12 target, # The Snowfall Lib target for this home (eg. `x86_64-home`).
13 format, # A normalized name for the home target (eg. `home`).
14 virtual, # A boolean to determine whether this home is a virtual target using nixos-generators.
15 host, # The host name for this home.
16
17 # All other arguments come from the home home.
18 config,
19 ...
20}:
21{
22 programs.git.extraConfig.alias = {
23 graph = "log --graph --oneline --decorate";
24 hash = "rev-parse HEAD";
25 };
26
27 home.shellAliases = {
28 I-FUCKING-SAID-PULL = "f(){ git reset --hard origin/\"$@\"; unset -f f; }; f";
29 mini = ''echo "you're using the wrong terminal"'';
30 };
31
32 programs.git.extraConfig.user = {
33 name = "PineaFan";
PineaFan60882cf2024-06-11 17:10:02 +010034 email = "ash@pinea.dev";
PineaFanfd2f8242024-04-20 20:51:36 +010035 signingkey = "8F50789F12AC6E6206EA870CE5E1C2D43B0E4AB3";
36 };
37
38 home.packages = [
39 pkgs.kate
40 pkgs.libsForQt5.kfind
41 pkgs.vlc
42 pkgs.obs-studio
43 pkgs.python312
44 pkgs.playerctl
PineaFan60882cf2024-06-11 17:10:02 +010045 pkgs.nodePackages.pnpm
PineaFanfd2f8242024-04-20 20:51:36 +010046 ];
47
48 programs.firefox.profiles.chimera.settings = {
49 "browser.startup.homepage" = "https://discord.com/app|https://matrix.clicks.codes";
50 };
51
52 chimera = {
53 nextcloud.enable = true;
54
PineaFanfd2f8242024-04-20 20:51:36 +010055 theme.catppuccin = {
56 enable = true;
57 style = "Macchiato";
58 color = "Mauve";
59 };
60
61 browser.chromium = {
62 enable = true;
63 };
64
65 browser.firefox = {
66 enable = true;
67 extensions = {
68 youtube = {
69 sponsorBlock.enable = true;
70 returnDislike.enable = true;
71 deArrow.enable = true;
72 };
73 adnauseam.enable = true;
74 };
75 };
76
77 input.keybinds = {
78 alternativeSearch.enable = true;
79 extraBinds = [
80 {
81 meta = "CTRL";
82 key = "1";
83 function = "exec, ${pkgs.pulseaudio}/bin/pactl set-default-sink $(${pkgs.pamixer}/bin/pamixer --list-sinks | grep \"Monitors\" | awk '{print $1}')";
84 }
85 {
86 meta = "CTRL";
87 key = "2";
88 function = "exec, ${pkgs.pulseaudio}/bin/pactl set-default-sink $(${pkgs.pamixer}/bin/pamixer --list-sinks | grep \"Razer Kraken V3\" | awk '{print $1}')";
89 }
PineaFan8be65d82024-04-23 21:08:33 +010090 {
91 key = "F1";
92 function = "exec, ~/Pictures/Wallpapers/change.sh light";
93 }
94 {
95 key = "F2";
96 function = "exec, ~/Pictures/Wallpapers/change.sh dark";
97 }
PineaFanfd2f8242024-04-20 20:51:36 +010098 ];
99 };
100
PineaFan8be65d82024-04-23 21:08:33 +0100101 startupApplications = [
102 "cd ~/Code/keyboard && python main.py"
103 ];
104
PineaFanfd2f8242024-04-20 20:51:36 +0100105 # input.mouse.scrolling.speedFactor = 0.45;
106 hyprland = {
107 hyprpaper.splash.enable = false;
108 enable = true;
109 monitors = [
PineaFan4a080ea2024-04-21 18:38:43 +0100110 "DP-1,1920x1080@60,-1920x0,1"
111 "HDMI-A-1,1920x1080@75,0x0,1"
112 "DP-2,1920x1080@60,1920x0,1"
PineaFanfd2f8242024-04-20 20:51:36 +0100113 ];
114 window = {
115 blur = 12;
116 rounding = 16;
117 };
118 };
119
120 shell = {
121 zsh.enable = true;
122 # zsh.theme = "crunch";
123 starship.enable = true;
124
125 rebuildFlakePath = "/home/pinea/Code/NixFiles";
126
127 defaultAliases.enable = true;
128 usefulPackages.enable = true;
129
130 replacements = {
131 defaultEnable = true;
132 atuin.enableUpArrow = true;
133 };
134 };
135
136 theme.font.nerdFontGlyphs.enable = true;
137 theme.wallpaper = ./wallpaper.png;
138
139 editor.nano = {
140 enable = true;
141 defaultEditor = false;
142 };
143
144 editor.neovim = {
145 enable = true;
146 defaultEditor = true;
147 };
148
Samuel Shuert219cf0b2024-03-30 17:53:08 -0400149 editor.editorconfig.enable = true;
150
PineaFanfd2f8242024-04-20 20:51:36 +0100151 input.keyboard = {
152 layout = "gb";
153 };
154
155 git = {
156 delta.enable = true;
157 gitReview.enable = true;
158 auth.clicksUsername = "pineafan";
159 gpg.enable = true;
PineaFan4a080ea2024-04-21 18:38:43 +0100160 stgit.enable = true;
PineaFanfd2f8242024-04-20 20:51:36 +0100161 };
162
163 games = {
164 minecraft.enable = true;
165 # itch.enable = true;
166 };
167
168 yubikey.enable = true;
169 yubikey.pam.enable = true;
170 yubikey.pam.key = "pinea:ZY1C32oFgQxsKlJEccxdI6rcdC8cZU8gWnBHMRgwb+MVvbRRqdYVHkIlXokscurAi5s/iQ5jnngDXUwG103ajQ==,m9X/BEHiXM1CrXu1u2zvItbd/Qa/tQGAxhIuD2NB2ohwo5d+vODwYl2faUnLhxcJexOWYBHOAzyWwwoeVRQFJw==,es256,+presence";
171
172 waybar.modules.temperature.enable = true;
173 waybar.modules.temperature.hwmonPath = "/sys/class/hwmon/hwmon1/temp1_input";
174 };
175
176 services.kdeconnect.enable = true;
177
178 programs.zsh = {
179 initExtra = ''
180 ${pkgs.pridefetch}/bin/pridefetch -f nonbinary -a
181 '';
182 };
183}