blob: e9b912ad85b4e93961811e7ea175ed078fc09890 [file] [log] [blame]
PineaFanfd2f8242024-04-20 20:51:36 +01001{
2 # Snowfall Lib provides a customized `lib` instance with access to your flake's library
3 # as well as the libraries available from your flake's inputs.
4 lib,
5 # An instance of `pkgs` with your overlays and packages applied is also available.
6 pkgs,
7 # You also have access to your flake's inputs.
8 inputs,
9
10 # Additional metadata is provided by Snowfall Lib.
11 home, # The home architecture for this host (eg. `x86_64-linux`).
12 target, # The Snowfall Lib target for this home (eg. `x86_64-home`).
13 format, # A normalized name for the home target (eg. `home`).
14 virtual, # A boolean to determine whether this home is a virtual target using nixos-generators.
15 host, # The host name for this home.
16
17 # All other arguments come from the home home.
18 config,
19 ...
20}:
21{
22 programs.git.extraConfig.alias = {
23 graph = "log --graph --oneline --decorate";
24 hash = "rev-parse HEAD";
25 };
26
27 home.shellAliases = {
28 I-FUCKING-SAID-PULL = "f(){ git reset --hard origin/\"$@\"; unset -f f; }; f";
29 mini = ''echo "you're using the wrong terminal"'';
30 };
31
32 programs.git.extraConfig.user = {
33 name = "PineaFan";
34 signingkey = "8F50789F12AC6E6206EA870CE5E1C2D43B0E4AB3";
35 };
36
37 home.packages = [
38 pkgs.kate
39 pkgs.libsForQt5.kfind
40 pkgs.vlc
41 pkgs.obs-studio
42 pkgs.python312
43 pkgs.playerctl
44 ];
45
46 programs.firefox.profiles.chimera.settings = {
47 "browser.startup.homepage" = "https://discord.com/app|https://matrix.clicks.codes";
48 };
49
50 chimera = {
51 nextcloud.enable = true;
52
53 nvidia.enable = true;
54
55 theme.catppuccin = {
56 enable = true;
57 style = "Macchiato";
58 color = "Mauve";
59 };
60
61 browser.chromium = {
62 enable = true;
63 };
64
65 browser.firefox = {
66 enable = true;
67 extensions = {
68 youtube = {
69 sponsorBlock.enable = true;
70 returnDislike.enable = true;
71 deArrow.enable = true;
72 };
73 adnauseam.enable = true;
74 };
75 };
76
77 input.keybinds = {
78 alternativeSearch.enable = true;
79 extraBinds = [
80 {
81 meta = "CTRL";
82 key = "1";
83 function = "exec, ${pkgs.pulseaudio}/bin/pactl set-default-sink $(${pkgs.pamixer}/bin/pamixer --list-sinks | grep \"Monitors\" | awk '{print $1}')";
84 }
85 {
86 meta = "CTRL";
87 key = "2";
88 function = "exec, ${pkgs.pulseaudio}/bin/pactl set-default-sink $(${pkgs.pamixer}/bin/pamixer --list-sinks | grep \"Razer Kraken V3\" | awk '{print $1}')";
89 }
90 ];
91 };
92
93 # input.mouse.scrolling.speedFactor = 0.45;
94 hyprland = {
95 hyprpaper.splash.enable = false;
96 enable = true;
97 monitors = [
98 "HDMI-A-1,1920x1080@75,1920x0,1"
99 "DVI-D-1,1920x1080@60,-1920x0,1"
100 "DP-1,1920x1080@60,0x0,1"
101 ];
102 window = {
103 blur = 12;
104 rounding = 16;
105 };
106 };
107
108 shell = {
109 zsh.enable = true;
110 # zsh.theme = "crunch";
111 starship.enable = true;
112
113 rebuildFlakePath = "/home/pinea/Code/NixFiles";
114
115 defaultAliases.enable = true;
116 usefulPackages.enable = true;
117
118 replacements = {
119 defaultEnable = true;
120 atuin.enableUpArrow = true;
121 };
122 };
123
124 theme.font.nerdFontGlyphs.enable = true;
125 theme.wallpaper = ./wallpaper.png;
126
127 editor.nano = {
128 enable = true;
129 defaultEditor = false;
130 };
131
132 editor.neovim = {
133 enable = true;
134 defaultEditor = true;
135 };
136
137 input.keyboard = {
138 layout = "gb";
139 };
140
141 git = {
142 delta.enable = true;
143 gitReview.enable = true;
144 auth.clicksUsername = "pineafan";
145 gpg.enable = true;
146 # stgit.enable = true;
147 };
148
149 games = {
150 minecraft.enable = true;
151 # itch.enable = true;
152 };
153
154 yubikey.enable = true;
155 yubikey.pam.enable = true;
156 yubikey.pam.key = "pinea:ZY1C32oFgQxsKlJEccxdI6rcdC8cZU8gWnBHMRgwb+MVvbRRqdYVHkIlXokscurAi5s/iQ5jnngDXUwG103ajQ==,m9X/BEHiXM1CrXu1u2zvItbd/Qa/tQGAxhIuD2NB2ohwo5d+vODwYl2faUnLhxcJexOWYBHOAzyWwwoeVRQFJw==,es256,+presence";
157
158 waybar.modules.temperature.enable = true;
159 waybar.modules.temperature.hwmonPath = "/sys/class/hwmon/hwmon1/temp1_input";
160 };
161
162 services.kdeconnect.enable = true;
163
164 programs.zsh = {
165 initExtra = ''
166 ${pkgs.pridefetch}/bin/pridefetch -f nonbinary -a
167 '';
168 };
169}