Skyler Grey | 4e23089 | 2024-02-13 22:58:46 +0000 | [diff] [blame] | 1 | { |
| 2 | # Snowfall Lib provides a customized `lib` instance with access to your flake's library |
| 3 | # as well as the libraries available from your flake's inputs. |
| 4 | lib, |
| 5 | # An instance of `pkgs` with your overlays and packages applied is also available. |
| 6 | pkgs, |
| 7 | # You also have access to your flake's inputs. |
| 8 | inputs, |
| 9 | |
| 10 | # Additional metadata is provided by Snowfall Lib. |
| 11 | home, # The home architecture for this host (eg. `x86_64-linux`). |
| 12 | target, # The Snowfall Lib target for this home (eg. `x86_64-home`). |
| 13 | format, # A normalized name for the home target (eg. `home`). |
| 14 | virtual, # A boolean to determine whether this home is a virtual target using nixos-generators. |
| 15 | host, # The host name for this home. |
| 16 | |
| 17 | # All other arguments come from the home home. |
| 18 | config, |
| 19 | ... |
| 20 | }: |
| 21 | { |
Samuel Shuert | cc979af | 2024-06-20 21:07:22 -0400 | [diff] [blame] | 22 | chimera.users.coded.enable = true; |
Samuel Shuert | 6d47eef | 2024-05-25 14:01:31 -0400 | [diff] [blame] | 23 | |
Samuel Shuert | cc979af | 2024-06-20 21:07:22 -0400 | [diff] [blame] | 24 | chimera.waybar.modules.temperature.hwmonPath = "/sys/class/hwmon/hwmon4/temp1_input"; |
Samuel Shuert | 6d47eef | 2024-05-25 14:01:31 -0400 | [diff] [blame] | 25 | |
Samuel Shuert | cc979af | 2024-06-20 21:07:22 -0400 | [diff] [blame] | 26 | chimera.niri = { |
| 27 | enable = true; |
Samuel Shuert | dab963e | 2024-03-23 19:54:28 -0400 | [diff] [blame] | 28 | |
Samuel Shuert | cc979af | 2024-06-20 21:07:22 -0400 | [diff] [blame] | 29 | monitors = { |
| 30 | "DP-1" = { |
| 31 | mode = { |
| 32 | width = 1920; |
| 33 | height = 1080; |
| 34 | refresh = 165.; |
| 35 | }; |
| 36 | position = { |
| 37 | x = 0; |
| 38 | y = 0; |
| 39 | }; |
Skyler Grey | 4cd2e0a | 2024-02-15 19:59:19 +0000 | [diff] [blame] | 40 | }; |
Samuel Shuert | cc979af | 2024-06-20 21:07:22 -0400 | [diff] [blame] | 41 | "DP-2" = { |
| 42 | mode = { |
| 43 | width = 1920; |
| 44 | height = 1080; |
| 45 | refresh = 165.; |
Samuel Shuert | 4d5c5fb | 2024-06-09 09:39:11 -0400 | [diff] [blame] | 46 | }; |
Samuel Shuert | cc979af | 2024-06-20 21:07:22 -0400 | [diff] [blame] | 47 | position = { |
| 48 | x = 1920; |
| 49 | y = 0; |
Samuel Shuert | 4d5c5fb | 2024-06-09 09:39:11 -0400 | [diff] [blame] | 50 | }; |
Samuel Shuert | cc979af | 2024-06-20 21:07:22 -0400 | [diff] [blame] | 51 | }; |
| 52 | "HDMI-A-1" = { |
| 53 | mode = { |
| 54 | width = 3840; |
| 55 | height = 2160; |
| 56 | refresh = 60.; |
| 57 | }; |
| 58 | position = { |
| 59 | x = 0; |
| 60 | y = -2160; |
Samuel Shuert | 4d5c5fb | 2024-06-09 09:39:11 -0400 | [diff] [blame] | 61 | }; |
Skyler Grey | 4e23089 | 2024-02-13 22:58:46 +0000 | [diff] [blame] | 62 | }; |
| 63 | }; |
Skyler Grey | 4e23089 | 2024-02-13 22:58:46 +0000 | [diff] [blame] | 64 | }; |
Samuel Shuert | 30eebdf | 2024-02-29 17:26:35 -0500 | [diff] [blame] | 65 | |
Samuel Shuert | cc979af | 2024-06-20 21:07:22 -0400 | [diff] [blame] | 66 | chimera.theme.wallpaper = ./wallpaper.png; |
Samuel Shuert | 6cc9e6d | 2024-03-01 17:14:04 -0500 | [diff] [blame] | 67 | |
Samuel Shuert | cc979af | 2024-06-20 21:07:22 -0400 | [diff] [blame] | 68 | # SSH Config |
| 69 | programs.ssh = { |
| 70 | enable = true; |
Samuel Shuert | 30eebdf | 2024-02-29 17:26:35 -0500 | [diff] [blame] | 71 | |
Samuel Shuert | cc979af | 2024-06-20 21:07:22 -0400 | [diff] [blame] | 72 | includes = [ "~/.ssh/config.d/*" ]; |
| 73 | |
| 74 | matchBlocks = { |
Samuel Shuert | cc979af | 2024-06-20 21:07:22 -0400 | [diff] [blame] | 75 | "github.com" = { |
| 76 | user = "git"; |
Samuel Shuert | 61647a9 | 2024-06-29 14:17:21 -0400 | [diff] [blame] | 77 | identityFile = [ "~/.ssh/ShorthairNanoResident" "~/.ssh/OnTheGo5cResident" ]; |
Samuel Shuert | cc979af | 2024-06-20 21:07:22 -0400 | [diff] [blame] | 78 | }; |
Samuel Shuert | 61647a9 | 2024-06-29 14:17:21 -0400 | [diff] [blame] | 79 | "greylag.minion" = { |
| 80 | identityFile = [ "~/.ssh/ShorthairNanoResident" "~/.ssh/OnTheGo5cResident" ]; |
| 81 | }; |
| 82 | "ocicat" = { |
| 83 | identityFile = [ "~/.ssh/ShorthairNanoResident" "~/.ssh/OnTheGo5cResident" ]; |
| 84 | }; |
| 85 | "git.auxolotl.org" = { |
| 86 | user = "forgejo"; |
| 87 | identityFile = [ "~/.ssh/ShorthairNanoResident" "~/.ssh/OnTheGo5cResident" ]; |
Samuel Shuert | edbbcc3 | 2024-06-27 15:36:45 -0400 | [diff] [blame] | 88 | }; |
Samuel Shuert | 30eebdf | 2024-02-29 17:26:35 -0500 | [diff] [blame] | 89 | }; |
Samuel Shuert | cc979af | 2024-06-20 21:07:22 -0400 | [diff] [blame] | 90 | }; |
Skyler Grey | 4e23089 | 2024-02-13 22:58:46 +0000 | [diff] [blame] | 91 | } |