Skyler Grey | 69a999e | 2024-05-23 00:09:10 +0000 | [diff] [blame] | 1 | { |
| 2 | lib, |
| 3 | config, |
| 4 | ... |
| 5 | }: { |
| 6 | options.chimera = { |
| 7 | wayland.enable = lib.mkOption { |
| 8 | type = lib.types.bool; |
| 9 | description = "Enable generic options which are useful for all wayland compositors"; |
| 10 | default = false; |
| 11 | internal = true; |
| 12 | }; |
| 13 | input.mouse.scrolling.natural = lib.mkEnableOption "Enable natural scrolling"; |
| 14 | input.touchpad.scrolling.natural = lib.mkOption { |
| 15 | type = lib.types.bool; |
| 16 | description = "Enable natural scrolling"; |
| 17 | default = config.chimera.input.mouse.scrolling.natural; |
| 18 | }; |
| 19 | input.keyboard = { |
| 20 | layout = lib.mkOption { |
| 21 | type = lib.types.str; |
| 22 | description = "Keyboard layouts, comma seperated"; |
| 23 | example = "us,de"; |
| 24 | default = "us"; |
| 25 | }; |
| 26 | variant = lib.mkOption { |
| 27 | type = lib.types.nullOr lib.types.str; |
| 28 | description = "Keyboard layout variants, comma seperated"; |
| 29 | example = "dvorak"; |
| 30 | default = null; |
| 31 | }; |
| 32 | }; |
| 33 | |
| 34 | input.keybinds.alternativeSearch.enable = lib.mkEnableOption "Use alt + space or SUPER + D to open search"; |
| 35 | |
| 36 | nvidia.enable = lib.mkEnableOption "Enable NVIDIA support"; |
| 37 | }; |
| 38 | |
| 39 | config = lib.mkIf config.chimera.wayland.enable { |
| 40 | chimera.waybar.enable = lib.mkDefault true; |
| 41 | chimera.notifications.mako.enable = true; |
| 42 | }; |
| 43 | } |