blob: eab8f4878083552e07f4f190d0f061a45c5d35e4 [file] [log] [blame]
PineaFancaf131b2024-10-04 20:15:31 +01001{...}: {
2 services.pipewire.extraConfig.pipewire."monitors" = {
3 "context.modules" = [
4 {
5 name = "libpipewire-module-combine-stream";
6 args = {
7 "combine.mode" = "sink";
8 "node.name" = "monitors";
9 "node.description" = "Monitors Auto";
10 "combine.latency-compensate" = false;
11 "combine.props" = {
12 "audio.position" = [ "FL" "FR" ];
13 };
14 "stream.props" = {
15 "stream.dont-remix" = true;
16 };
17 "stream.rules" = [
18 {
19 matches = [
20 {
21 "media.class" = "Audio/Sink";
22 "node.name" = "alsa_output.pci-0000_0a_00.1.pro-output-7";
23 }
24 ];
25 actions = {
26 create-stream = {
27 "audio.position" = [ "AUX0" "AUX1" ];
28 "combine.audio.position" = [ "FL" ];
29 };
30 };
31 }
32 {
33 matches = [
34 {
35 "media.class" = "Audio/Sink";
36 "node.name" = "alsa_output.pci-0000_0a_00.1.pro-output-9";
37 }
38 ];
39 actions = {
40 create-stream = {
41 "audio.position" = [ "AUX0" "AUX1" ];
42 "combine.audio.position" = [ "FR" ];
43 };
44 };
45 }
46 ];
47 };
48 }
49 ];
50 };
51}