blob: bc87703ced6e163795a9ec631b1025096fc439bc [file] [log] [blame]
Samuel Shuertd7d2fe22024-01-25 15:20:24 -05001{
2 description = "A basic flake with a shell";
3 inputs.nixpkgs.url = "github:NixOS/nixpkgs/nixpkgs-unstable";
4 inputs.flake-utils.url = "github:numtide/flake-utils";
5
6
7 outputs = { nixpkgs, flake-utils, ... }:
8 flake-utils.lib.eachDefaultSystem (system:
9 let
10 pkgs = import nixpkgs {
11 inherit system;
12 };
13 in
14 {
15 devShells.default = pkgs.mkShell {
16 packages = [
17 pkgs.bun
18 pkgs.nodejs_21
19 ];
20 };
21 });
22}