Many things

Change-Id: I147b761e6ba157e77bb374c3e0191533a03a92a3
diff --git a/modules/hardware-configuration.nix b/modules/hardware-configuration.nix
index ae6ebae..6c861fb 100755
--- a/modules/hardware-configuration.nix
+++ b/modules/hardware-configuration.nix
@@ -8,8 +8,8 @@
 
   boot.initrd.availableKernelModules =
     [ "nvme" "xhci_pci" "ahci" "usb_storage" "usbhid" "sd_mod" "sr_mod" ];
-  boot.initrd.kernelModules = [ ];
-  boot.kernelModules = [ "kvm-amd" ];
+  boot.initrd.kernelModules = [ "amdgpu" ];
+  boot.kernelModules = [ ];
   boot.extraModulePackages = [ ];
 
   fileSystems."/" = {