| # Do not modify this file! It was generated by ‘nixos-generate-config’ |
| # and may be overwritten by future invocations. Please make changes |
| # to /etc/nixos/configuration.nix instead. |
| { config, lib, pkgs, modulesPath, ... }: |
| |
| { |
| imports = [ (modulesPath + "/installer/scan/not-detected.nix") ]; |
| |
| boot.initrd.availableKernelModules = |
| [ "nvme" "xhci_pci" "ahci" "usb_storage" "usbhid" "sd_mod" "sr_mod" ]; |
| boot.initrd.kernelModules = [ "amdgpu" ]; |
| boot.kernelModules = [ ]; |
| boot.extraModulePackages = [ ]; |
| |
| fileSystems."/" = { |
| device = "/dev/disk/by-uuid/63caf2b5-90d4-49a7-99e9-98dcdd797859"; |
| fsType = "ext4"; |
| }; |
| |
| boot.initrd.luks.devices."luks-c38bc921-8979-4a25-9520-f3354dee3557".device = |
| "/dev/disk/by-uuid/c38bc921-8979-4a25-9520-f3354dee3557"; |
| |
| fileSystems."/boot" = { |
| device = "/dev/disk/by-uuid/5B78-4B2D"; |
| fsType = "vfat"; |
| }; |
| |
| swapDevices = |
| [{ device = "/dev/disk/by-uuid/3a9212d4-6c39-4d5b-abf0-49294bd991c9"; }]; |
| |
| # Enables DHCP on each ethernet and wireless interface. In case of scripted networking |
| # (the default) this is the recommended approach. When using systemd-networkd it's |
| # still possible to use this option, but it's recommended to use it in conjunction |
| # with explicit per-interface declarations with `networking.interfaces.<interface>.useDHCP`. |
| networking.useDHCP = lib.mkDefault true; |
| # networking.interfaces.enp42s0.useDHCP = lib.mkDefault true; |
| # networking.interfaces.wlo1.useDHCP = lib.mkDefault true; |
| |
| nixpkgs.hostPlatform = lib.mkDefault "x86_64-linux"; |
| hardware.cpu.amd.updateMicrocode = |
| lib.mkDefault config.hardware.enableRedistributableFirmware; |
| } |