blob: a24e69173acbb776d9fde5f3d97a1acda8586d6d [file] [log] [blame]
Samuel Shuert504b0fd2024-02-11 14:39:15 -05001{ pkgs, inputs, flakeRoot, system, ... }: {
2
3 programs.hyprland.enable = true;
4
5 home-manager.users.coded = {
6 home.packages = [ pkgs.hyprpicker ];
7
8 wayland.windowManager.hyprland = {
9 enable = true;
10
11 xwayland.enable = true;
12 systemd.enable = true;
13
14 plugins = [
15
16 ];
17
18 settings = let
19 mod = "SUPER";
20 terminal = "kitty";
21 menu = "anyrun";
22 reloadWallpaper = "${inputs.nixpkgs-unstable.legacyPackages.${system}.hyprpaper}/bin/hyprpaper";
23 in {
24 exec-once = "${reloadWallpaper}";
25
26 general = {
27 gaps_in = 5;
28 gaps_out = 20;
29
30 border_size = 2;
31 "col.active_border" = "rgba(71AEF5EE) rgba(F2D478EE) 45deg";
32 "col.inactive_border" = "rgba(C4C4C4EE)";
33
34 layout = "dwindle";
35 };
36
37 decoration = {
38 rounding = 10;
39
40 drop_shadow = true;
41 shadow_range = 4;
42 shadow_render_power = 3;
43 "col.shadow" = "rgba(1a1a1aee)";
44 };
45
46 input = {
47 kb_layout = "us";
48 numlock_by_default = true;
49 };
50
51 monitor = [
52 "DP-1,1920x1080@165,0x0,1"
53 "DP-2,1920x1080@165,1920x0,1"
54 "HDMI-A-1,1920x1080@60,960x-1080,1"
55 ",preferred,auto,1"
56 ];
57
58 xwayland = {
59 force_zero_scaling = true;
60 };
61
62 master = {
63 new_is_master = true;
64 };
65
66 bind = [
67 "${mod}, Q, killactive"
68 "${mod}, SPACE, togglefloating"
69 "${mod}, RETURN, exec, ${terminal}"
70 "${mod}, down, movefocus, d"
71 "${mod}, up, movefocus, u"
72 "${mod}, right, movefocus, r"
73 "${mod}, left, movefocus, l"
74
75 "${mod} SHIFT, R, exec, ${reloadWallpaper}"
76
77 "ALT, SPACE, exec, ${menu}"
78 ] ++ (
79 builtins.concatLists (builtins.genList (
80 x: let
81 ws = let
82 c = (x + 1) / 10;
83 in
84 builtins.toString (x + 1 - (c * 10));
85 in [
86 "${mod}, ${ws}, workspace, ${toString (x + 1)}"
87 "${mod} SHIFT, ${ws}, movetoworkspace, ${toString (x + 1)}"
88 ]
89 )
90 10)
91 );
92
93 bindm = [
94 "${mod}, mouse:272, movewindow"
95 "${mod}, mouse:273, resizewindow"
96 ];
97
98 misc = {
99 force_default_wallpaper = 0;
100 };
101 };
102 };
103 };
104}