Samuel Shuert | f1d6e99 | 2023-11-24 17:28:33 -0500 | [diff] [blame^] | 1 | { lib, ... }: { |
| 2 | boot = { |
| 3 | supportedFilesystems = [ "ntfs" ]; |
| 4 | bootspec.enable = true; |
| 5 | loader.systemd-boot = { |
| 6 | enable = lib.mkForce false; |
| 7 | }; |
| 8 | lanzaboote = { |
| 9 | enable = true; |
| 10 | pkiBundle = "/etc/secureboot"; |
| 11 | |
| 12 | settings = { |
| 13 | auto-entries = true; |
| 14 | }; |
| 15 | |
| 16 | }; |
| 17 | loader.efi.canTouchEfiVariables = true; |
| 18 | initrd.luks.devices."luks-bf23eee1-7cb7-43b9-822f-a9f49ea0a768".device = |
| 19 | "/dev/disk/by-uuid/bf23eee1-7cb7-43b9-822f-a9f49ea0a768"; |
| 20 | |
| 21 | initrd.kernelModules = [ "amdgpu" ]; |
| 22 | }; |
| 23 | } |