Samuel Shuert | f1d6e99 | 2023-11-24 17:28:33 -0500 | [diff] [blame^] | 1 | { pkgs, config, inputs, ... }: { |
| 2 | programs.zsh.enable = true; |
| 3 | users.users.coded.shell = pkgs.zsh; |
| 4 | |
| 5 | home-manager.users.coded.programs = { |
| 6 | # ZSH |
| 7 | zsh = { |
| 8 | enable = true; |
| 9 | enableAutosuggestions = true; |
| 10 | enableCompletion = true; |
| 11 | autocd = true; |
| 12 | defaultKeymap = "emacs"; |
| 13 | |
| 14 | shellAliases = { |
| 15 | rebuild = "sudo nixos-rebuild switch --flake /home/coded/nixConfig/"; |
| 16 | "gr!" = "git review"; |
| 17 | clr = "clear"; |
| 18 | pnpx = "pnpm dlx"; |
| 19 | }; |
| 20 | |
| 21 | dirHashes = { code = "$HOME/Documents/programming"; }; |
| 22 | |
| 23 | history = { extended = true; }; |
| 24 | historySubstringSearch.enable = true; |
| 25 | |
| 26 | oh-my-zsh = { |
| 27 | enable = true; |
| 28 | plugins = [ "git" ]; |
| 29 | }; |
| 30 | }; |
| 31 | |
| 32 | # Starship |
| 33 | starship = { |
| 34 | enable = true; |
| 35 | settings = { format = "$all"; }; |
| 36 | }; |
| 37 | |
| 38 | # Alacritty |
| 39 | alacritty = { |
| 40 | enable = true; |
| 41 | settings = { |
| 42 | window.dimensions = { |
| 43 | lines = 40; |
| 44 | columns = 150; |
| 45 | }; |
| 46 | import = [ |
| 47 | "${inputs.alacritty-themes}/themes/Catppuccin-Mocha.yml" |
| 48 | ]; |
| 49 | }; |
| 50 | }; |
| 51 | |
| 52 | # htop |
| 53 | # htop = { |
| 54 | # enable = true; |
| 55 | # settings = { |
| 56 | # color_scheme = 6; |
| 57 | # cpu_count_from_one = 0; |
| 58 | # delay = 15; |
| 59 | # fields = with home-manager.config.lib.htop.fields; [ |
| 60 | # PID |
| 61 | # USER |
| 62 | # PERCENT_CPU |
| 63 | # PERCENT_MEM |
| 64 | # M_SIZE |
| 65 | # M_RESIDENT |
| 66 | # M_SHARE |
| 67 | # STATE |
| 68 | # TIME |
| 69 | # COMM |
| 70 | # ]; |
| 71 | # } // (with home-manager.config.lib.htop; leftMeters [ |
| 72 | # (bar "AllCPUs2") |
| 73 | # (bar "Memory") |
| 74 | # (bar "Swap") |
| 75 | # (text "Zram") |
| 76 | # ]) // (with home-manager.config.lib.htop; rightMeters [ |
| 77 | # (text "Tasks") |
| 78 | # (text "LoadAverage") |
| 79 | # (text "Uptime") |
| 80 | # (text "Systemd") |
| 81 | # ]); |
| 82 | # }; |
| 83 | |
| 84 | # Nix-index |
| 85 | nix-index.enable = true; |
| 86 | |
| 87 | # thefuck |
| 88 | thefuck = { |
| 89 | enable = true; |
| 90 | enableInstantMode = true; |
| 91 | }; |
| 92 | }; |
| 93 | |
| 94 | environment.pathsToLink = |
| 95 | [ "/share/zsh" ]; # needed for completing system packages |
| 96 | } |