# SPDX-FileCopyrightText: 2024 Auxolotl Infrastructure Contributors | |
# SPDX-FileCopyrightText: 2024 Clicks Codes | |
# | |
# SPDX-License-Identifier: GPL-3.0-only | |
{ lib, config, ... }: | |
let | |
cfg = config.clicks.services.ssh; | |
in | |
{ | |
options.clicks.services.ssh = { | |
enable = lib.mkEnableOption "SSH"; | |
}; | |
config = lib.mkIf cfg.enable { | |
services.openssh = { | |
enable = true; | |
}; | |
}; | |
} |