Move to deploy-rs, add basic configuration
diff --git a/host/shell.nix b/host/shell.nix
new file mode 100644
index 0000000..cc2e6d5
--- /dev/null
+++ b/host/shell.nix
@@ -0,0 +1,13 @@
+{ pkgs, ... }: {
+    users.defaultUserShell = pkgs.zsh;
+
+    programs.zsh = {
+        enable = true;
+        ohMyZsh = [ "zsh-syntax-highlighting" "git" "git-auto-fetch" "gh" ];
+        autosuggestions = {
+            enable = true;
+            async = true;
+        };
+        syntaxHighlighting.enable = true;
+    };
+}