Add a script for root to easily mount mongodb and force a static ip
diff --git a/flake.nix b/flake.nix
index c43c3e1..ccf714a 100644
--- a/flake.nix
+++ b/flake.nix
@@ -58,6 +58,7 @@
               ./modules/postgres.nix
               ./modules/samba.nix
               ./modules/scalpel.nix
+              ./modules/static-ip.nix
               ./modules/tesseract.nix
               sops-nix.nixosModules.sops
               {
@@ -123,6 +124,38 @@
             }))
             builtins.listToAttrs
           ]
+        ) // (
+          let
+            mkBlankConfig = username:
+              {
+                remoteBuild = true;
+                user = username;
+
+                profilePath = "/nix/var/nix/profiles/per-user/${username}/home-manager";
+                path =
+                  deploy-rs.lib.x86_64-linux.activate.home-manager (home-manager.lib.homeManagerConfiguration
+                    {
+                      inherit pkgs;
+                      modules = [
+                        {
+                          home.username = username;
+                          home.stateVersion = "22.11";
+                          programs.home-manager.enable = true;
+                        }
+                        "${./homes}/${username}"
+                      ];
+                    });
+              };
+          in
+          nixpkgs.lib.pipe ./homes [
+            builtins.readDir
+            (nixpkgs.lib.filterAttrs (_name: value: value == "directory"))
+            builtins.attrNames
+            (map (name: {
+              inherit name; value = mkBlankConfig name;
+            }))
+            builtins.listToAttrs
+          ]
         );
         hostname = "clicks";
         profilesOrder = [ "system" ];