blob: c43c3e1af9a4a9d4c20dee86af3e248c68704830 [file] [log] [blame]
Skyler Grey1e2187f2023-03-03 22:45:10 +00001{
2 description = "A flake to deploy and configure Clicks' NixOS server";
3
Skyler Grey07584fb2023-05-01 21:37:13 +00004 inputs.nixpkgs.url = "github:nixos/nixpkgs/nixos-22.11";
Skyler Greya7fbaee2023-05-12 00:29:20 +00005 inputs.nixpkgs-unstable.url = "github:nixos/nixpkgs/nixpkgs-unstable";
Skyler Grey061574c2023-05-01 21:39:24 +00006 inputs.flake-utils.url = "github:numtide/flake-utils";
Skyler Grey1e2187f2023-03-03 22:45:10 +00007 inputs.deploy-rs.url = "github:serokell/deploy-rs";
Skyler Grey07584fb2023-05-01 21:37:13 +00008 inputs.home-manager.url = "github:nix-community/home-manager/release-22.11";
Skyler Greya7fbaee2023-05-12 00:29:20 +00009 inputs.sops-nix.url = "github:Mic92/sops-nix";
Skyler Greya78aa672023-05-20 13:48:18 +020010 inputs.scalpel.url = "github:polygon/scalpel";
Skyler Grey1e2187f2023-03-03 22:45:10 +000011
Skyler Greyfed0bb12023-05-01 21:42:03 +000012 inputs.home-manager.inputs.nixpkgs.follows = "nixpkgs";
13 inputs.home-manager.inputs.utils.follows = "deploy-rs/utils";
14
Skyler Greya7fbaee2023-05-12 00:29:20 +000015 inputs.sops-nix.inputs.nixpkgs.follows = "nixpkgs";
16
Skyler Greya78aa672023-05-20 13:48:18 +020017 inputs.scalpel.inputs.nixpkgs.follows = "nixpkgs";
18 inputs.scalpel.inputs.sops-nix.follows = "sops-nix";
19
20 outputs = { self, nixpkgs, deploy-rs, home-manager, sops-nix, scalpel, nixpkgs-unstable, ... }@inputs:
Skyler Grey07584fb2023-05-01 21:37:13 +000021 let
22 system = "x86_64-linux";
23 pkgs = import nixpkgs {
24 inherit system;
25 config.allowUnfree = true;
26 };
Skyler Greya7fbaee2023-05-12 00:29:20 +000027 pkgs-unstable = import nixpkgs-unstable {
28 inherit system;
29 config.allowUnfree = true;
30 };
Skyler Grey07584fb2023-05-01 21:37:13 +000031 in
Skyler Greyb3516c22023-05-24 19:17:11 +020032 rec {
Skyler Grey07584fb2023-05-01 21:37:13 +000033 nixosConfigurations.clicks =
Skyler Greya78aa672023-05-20 13:48:18 +020034 let
35 base = nixpkgs.lib.nixosSystem {
36 inherit system pkgs;
37 modules = [
38 ./default/configuration.nix
39 ./default/hardware-configuration.nix
40 ./modules/caddy.nix
41 ./modules/clamav.nix
42 ./modules/code-server.nix
43 ./modules/dmarc.nix
44 ./modules/dnsmasq.nix
45 ./modules/doas.nix
46 ./modules/docker.nix
47 ./modules/ecryptfs.nix
48 ./modules/fail2ban.nix
49 ./modules/fuck.nix
50 ./modules/git.nix
51 ./modules/grafana.nix
52 ./modules/home-manager-users.nix
53 ./modules/kitty.nix
Skyler Grey480fd8b2023-05-24 19:11:16 +020054 ./modules/loginctl-linger.nix
Skyler Greya78aa672023-05-20 13:48:18 +020055 ./modules/matrix.nix
56 ./modules/mongodb.nix
57 ./modules/node.nix
58 ./modules/postgres.nix
59 ./modules/samba.nix
60 ./modules/scalpel.nix
61 ./modules/tesseract.nix
62 sops-nix.nixosModules.sops
63 {
64 users.mutableUsers = false;
65 _module.args = { inherit pkgs-unstable; };
66 }
67 ];
68 specialArgs = { base = null; };
69 };
70 in
71 base.extendModules {
Skyler Grey07584fb2023-05-01 21:37:13 +000072 modules = [
Skyler Greya78aa672023-05-20 13:48:18 +020073 scalpel.nixosModules.scalpel
Skyler Grey07584fb2023-05-01 21:37:13 +000074 ];
Skyler Greya78aa672023-05-20 13:48:18 +020075 specialArgs = { inherit base; };
Skyler Grey4f3e6062023-03-04 01:29:29 +000076 };
Skyler Grey07584fb2023-05-01 21:37:13 +000077
Skyler Greyb3516c22023-05-24 19:17:11 +020078 nixosConfigurations.clicks-without-mongodb =
79 nixosConfigurations.clicks.extendModules {
80 modules = [
81 { services.mongodb.enable = nixpkgs.lib.mkForce false; }
82 ];
83 };
84
Skyler Grey07584fb2023-05-01 21:37:13 +000085 deploy.nodes.clicks = {
86 sudo = "doas -u";
87 profiles = {
88 system = {
89 remoteBuild = true;
90 user = "root";
91 path = deploy-rs.lib.x86_64-linux.activate.nixos
92 self.nixosConfigurations.clicks;
93 };
94 } // (
95 let
96 mkServiceConfig = service: {
97 remoteBuild = true;
98 user = service;
99
100 profilePath = "/nix/var/nix/profiles/per-user/${service}/home-manager";
101 path =
102 deploy-rs.lib.x86_64-linux.activate.home-manager (home-manager.lib.homeManagerConfiguration
103 {
104 inherit pkgs;
105 modules = [
106 {
107 home.homeDirectory = "/services/${service}";
108 home.username = service;
109 home.stateVersion = "22.11";
110 programs.home-manager.enable = true;
111 }
112 "${./services}/${service}"
113 ];
114 });
115 };
116 in
117 nixpkgs.lib.pipe ./services [
118 builtins.readDir
119 (nixpkgs.lib.filterAttrs (_name: value: value == "directory"))
120 builtins.attrNames
121 (map (name: {
122 inherit name; value = mkServiceConfig name;
123 }))
124 builtins.listToAttrs
125 ]
126 );
127 hostname = "clicks";
128 profilesOrder = [ "system" ];
Skyler Grey1e2187f2023-03-03 22:45:10 +0000129 };
Skyler Grey1e2187f2023-03-03 22:45:10 +0000130
Skyler Grey07584fb2023-05-01 21:37:13 +0000131 formatter.x86_64-linux = nixpkgs.legacyPackages.x86_64-linux.nixpkgs-fmt;
Skyler Grey1e2187f2023-03-03 22:45:10 +0000132 };
Skyler Grey1e2187f2023-03-03 22:45:10 +0000133}