blob: 33f8a49d87780006dd83c2955cc1d36fe3d9a981 [file] [log] [blame]
{ config, pkgs, lib, ... }: {
systemd.services.jinx = { # running for Pinea
serviceConfig = {
User = "jinx";
ExecStart = "${pkgs.nix}/bin/nix develop --command pnpm start";
WorkingDirectory = "/services/jinx/Jinx";
LoadCredential = "postgres_password:${config.sops.secrets.clicks_jinx_db_password.path}";
Environment = [
"PATH=${pkgs.git}/bin"
"DATABASE_PASSWORD_FILE=%d/postgres_password"
];
};
wantedBy = [ "default.target" ];
description = "Run Jinx";
};
}