Update to NixOS 23.11
Most of the release notes we have the luxury of not caring about, however
for some we needed to make changes
- postgresql ensurePermissions was deprecated. We have replaced it with a
combination of the new ensureDBOwner, and manual permissions grants
where that is not applicable
- fetchPypi should now be used at top-level. We used it once to install
jishaku for ClicksForms. We have replaced the usage. There should be a
broader conversation about the future of ClicksForms, but while
upgrading to 23.11 is probably not the time for that
- fail2ban configs for things we no longer run have been removed
Additionally, the following things were looked at in-detail and deemed
non-important
- passwordFile changes (we do not use passwords, at all)
- matrix changes (we believe this will need no module changes for our
use-case)
- nextcloud phpOptions changes (this may reintroduce some default PHP
options. We didn't realize we were clobbering them and consider this to
be a good thing)
- vaultwarden default host change (we already specify a host)
- RAID changes (neither a1d1 or a1d2 currently use software RAID)
- nixpkgs.config with external packages warnings (we don't use any
nixpkgs.config options, but if we did we could remove them and) keep
the same behavior
- nextcloud upgrade to 27 (we already use nextcloud 27)
- matrix workers and redis configuration (redis doesn't provide a benefit
outside of workers, our deployment is too small to need workers)
- several services have improved requirements. In particular, lots of
dependencies around postgres have been improved
We haven't yet updated mongodb, it may be a good idea to migrate to
ferretdb but this is better placed in a later change as migration will
require migrating all the data which will likely get messy
Change-Id: I8db3cc5bfa68bc591ef5e467e8c7de0cae30b300
Reviewed-on: https://git.clicks.codes/c/Clicks/NixFiles/+/122
Tested-by: Samuel Shuert <coded@clicks.codes>
Reviewed-by: Samuel Shuert <coded@clicks.codes>
diff --git a/flake.nix b/flake.nix
index a497863..482f247 100644
--- a/flake.nix
+++ b/flake.nix
@@ -2,11 +2,11 @@
description = "A flake to deploy and configure Clicks' NixOS server";
# input URLs
- inputs.nixpkgs.url = "github:nixos/nixpkgs/nixos-23.05";
+ inputs.nixpkgs.url = "github:nixos/nixpkgs/nixos-23.11";
inputs.nixpkgs-clicksforms.url = "github:nixos/nixpkgs/nixos-22.05";
inputs.flake-utils.url = "github:numtide/flake-utils";
inputs.deploy-rs.url = "github:serokell/deploy-rs";
- inputs.home-manager.url = "github:nix-community/home-manager/release-23.05";
+ inputs.home-manager.url = "github:nix-community/home-manager/release-23.11";
inputs.sops-nix.url = "github:Mic92/sops-nix";
inputs.scalpel.url = "github:polygon/scalpel";