# SPDX-FileCopyrightText: 2024 Clicks Codes | |
# | |
# SPDX-License-Identifier: GPL-3.0-only | |
{ lib, ... }: { | |
testSuccess = { | |
expr = lib.clicks.nginx.http.status 200; | |
expected = { | |
code = 200; | |
_type = "status"; | |
headers = null; | |
}; | |
}; | |
testNotFound = { | |
expr = lib.clicks.nginx.http.status 404; | |
expected = { | |
code = 404; | |
_type = "status"; | |
headers = null; | |
}; | |
}; | |
} |