Skyler Grey | f08a619 | 2024-06-01 23:55:20 +0000 | [diff] [blame] | 1 | # SPDX-FileCopyrightText: 2024 Clicks Codes |
| 2 | # |
| 3 | # SPDX-License-Identifier: GPL-3.0-only |
| 4 | |
| 5 | { |
| 6 | config, |
| 7 | lib, |
| 8 | pkgs, |
| 9 | ... |
| 10 | }: |
| 11 | { |
| 12 | options = { |
Skyler Grey | 05e11c1 | 2024-06-15 00:02:15 +0000 | [diff] [blame^] | 13 | clicks.users = { |
| 14 | deployers = lib.mkOption { |
| 15 | type = lib.types.listOf lib.types.str; |
| 16 | default = [ ]; |
| 17 | description = "Users who should be allowed to deploy to this server. They will be given passwordless access to run commands as root"; |
| 18 | }; |
| 19 | backups = lib.mkOption { |
| 20 | type = lib.types.listOf lib.types.str; |
| 21 | default = [ ]; |
| 22 | description = "Accounts used to create snapshots to backup this server. They will be given passwordless access to run commands as root"; |
| 23 | }; |
Skyler Grey | f08a619 | 2024-06-01 23:55:20 +0000 | [diff] [blame] | 24 | }; |
| 25 | }; |
| 26 | } |