Skyler Grey | 1e2187f | 2023-03-03 22:45:10 +0000 | [diff] [blame] | 1 | # Do not modify this file! It was generated by ‘nixos-generate-config’ |
| 2 | # and may be overwritten by future invocations. Please make changes |
| 3 | # to /etc/nixos/configuration.nix instead. |
Samuel Shuert | f68685d | 2023-10-28 20:07:56 -0400 | [diff] [blame] | 4 | { config, lib, pkgs, modulesPath, ... }: |
Skyler Grey | 1e2187f | 2023-03-03 22:45:10 +0000 | [diff] [blame] | 5 | |
| 6 | { |
Samuel Shuert | f68685d | 2023-10-28 20:07:56 -0400 | [diff] [blame] | 7 | imports = [ (modulesPath + "/installer/scan/not-detected.nix") ]; |
| 8 | |
Skyler Grey | fe1740c | 2023-10-21 01:24:18 +0000 | [diff] [blame] | 9 | boot.initrd.availableKernelModules = |
Samuel Shuert | f68685d | 2023-10-28 20:07:56 -0400 | [diff] [blame] | 10 | [ "nvme" "xhci_pci" "usbhid" "usb_storage" "sd_mod" ]; |
Skyler Grey | 1e2187f | 2023-03-03 22:45:10 +0000 | [diff] [blame] | 11 | boot.initrd.kernelModules = [ ]; |
| 12 | boot.kernelModules = [ "kvm-amd" ]; |
| 13 | boot.extraModulePackages = [ ]; |
| 14 | |
Skyler Grey | fe1740c | 2023-10-21 01:24:18 +0000 | [diff] [blame] | 15 | fileSystems."/" = { |
Samuel Shuert | f68685d | 2023-10-28 20:07:56 -0400 | [diff] [blame] | 16 | device = "/dev/disk/by-uuid/0456a002-1692-4ed0-a233-d6cd76c8c2dd"; |
| 17 | fsType = "btrfs"; |
Skyler Grey | fe1740c | 2023-10-21 01:24:18 +0000 | [diff] [blame] | 18 | }; |
Skyler Grey | 1e2187f | 2023-03-03 22:45:10 +0000 | [diff] [blame] | 19 | |
Samuel Shuert | f68685d | 2023-10-28 20:07:56 -0400 | [diff] [blame] | 20 | boot.initrd.luks.devices."luks-ssd0".device = |
| 21 | "/dev/disk/by-uuid/a50b2c75-dd36-4d31-924f-d4b77b94efa9"; |
| 22 | |
Skyler Grey | fe1740c | 2023-10-21 01:24:18 +0000 | [diff] [blame] | 23 | fileSystems."/boot" = { |
Samuel Shuert | f68685d | 2023-10-28 20:07:56 -0400 | [diff] [blame] | 24 | device = "/dev/disk/by-uuid/9416-209A"; |
Skyler Grey | fe1740c | 2023-10-21 01:24:18 +0000 | [diff] [blame] | 25 | fsType = "vfat"; |
| 26 | }; |
Skyler Grey | 1e2187f | 2023-03-03 22:45:10 +0000 | [diff] [blame] | 27 | |
| 28 | swapDevices = |
Samuel Shuert | f68685d | 2023-10-28 20:07:56 -0400 | [diff] [blame] | 29 | [{ device = "/dev/disk/by-uuid/a1cb08ad-39b3-4a36-bf5a-fad7714a85c0"; }]; |
Skyler Grey | 1e2187f | 2023-03-03 22:45:10 +0000 | [diff] [blame] | 30 | |
| 31 | # Enables DHCP on each ethernet and wireless interface. In case of scripted networking |
| 32 | # (the default) this is the recommended approach. When using systemd-networkd it's |
| 33 | # still possible to use this option, but it's recommended to use it in conjunction |
| 34 | # with explicit per-interface declarations with `networking.interfaces.<interface>.useDHCP`. |
| 35 | networking.useDHCP = lib.mkDefault true; |
Samuel Shuert | f68685d | 2023-10-28 20:07:56 -0400 | [diff] [blame] | 36 | # networking.interfaces.enp1s0.useDHCP = lib.mkDefault true; |
| 37 | # networking.interfaces.wlo1.useDHCP = lib.mkDefault true; |
Skyler Grey | 1e2187f | 2023-03-03 22:45:10 +0000 | [diff] [blame] | 38 | |
| 39 | nixpkgs.hostPlatform = lib.mkDefault "x86_64-linux"; |
Skyler Grey | fe1740c | 2023-10-21 01:24:18 +0000 | [diff] [blame] | 40 | hardware.cpu.amd.updateMicrocode = |
| 41 | lib.mkDefault config.hardware.enableRedistributableFirmware; |
Skyler Grey | 1e2187f | 2023-03-03 22:45:10 +0000 | [diff] [blame] | 42 | } |