blob: 925713793af9cd97a5d017301806d7317dac9d62 [file] [log] [blame]
Skyler Grey2c9c3e72024-07-17 22:00:16 +00001{ lib
2, python3
3}: let
4 pname = "smart_importer";
5 version = "0.5";
6in python3.pkgs.buildPythonApplication {
7 inherit pname version;
8
9 src = python3.pkgs.fetchPypi {
10 inherit pname version;
11 sha256 = "sha256-n0mBayg3Ny/5eHByonDnqpDeErv3tDhp577cCoM6l1I=";
12 };
13
14 format = "pyproject";
15
16 propagatedBuildInputs = [
17 python3.pkgs.beancount
18 python3.pkgs.scikit-learn
19 python3.pkgs.numpy
20 ];
21
22 buildInputs = [
23 python3.pkgs.setuptools
24 python3.pkgs.setuptools_scm
25 ];
26
27 meta = {
28 homepage = "https://github.com/beancount/smart_importer";
29 description = "Augment Beancount importers with machine learning functionality";
30 license = lib.licenses.mit;
31 maintainers = [ lib.maintainers.minion3665 ];
32 };
33}