Skyler Grey | 3299e4f | 2024-07-04 00:33:43 +0000 | [diff] [blame] | 1 | # SPDX-FileCopyrightText: 2024 Clicks Codes |
| 2 | # |
| 3 | # SPDX-License-Identifier: GPL-3.0-only |
| 4 | |
| 5 | { config, inputs, lib, system, ... }: |
| 6 | |
| 7 | { |
| 8 | options.clicks.sites."docs.auxolotl.org".enable = lib.options.mkEnableOption "Enable hosting https://docs.auxolotl.org"; |
| 9 | |
| 10 | config = lib.modules.mkIf config.clicks.sites."docs.auxolotl.org".enable { |
| 11 | clicks.services.nginx = { |
| 12 | enable = true; |
| 13 | |
| 14 | hosts."docs.auxolotl.org" = { |
| 15 | service = lib.clicks.nginx.http.directory "${builtins.toString inputs.aux--docs-site.packages.${system}.default}"; |
| 16 | www = false; |
| 17 | }; |
| 18 | }; |
| 19 | }; |
| 20 | } |