blob: 67b4d86de857dec78673bd3aa76475fc403f1b20 [file] [log] [blame]
Skyler Greyd7e1acd2024-06-22 14:42:11 +00001# SPDX-FileCopyrightText: 2024 Clicks Codes
2#
3# SPDX-License-Identifier: GPL-3.0-only
4
5{ lib, ... }: {
6 testSuccess = {
7 expr = lib.clicks.nginx.http.status 200;
8 expected = {
9 code = 200;
10 _type = "status";
11 headers = null;
12 };
13 };
14 testNotFound = {
15 expr = lib.clicks.nginx.http.status 404;
16 expected = {
17 code = 404;
18 _type = "status";
19 headers = null;
20 };
21 };
22}