Skyler Grey | 52d38f1 | 2023-12-11 19:02:41 +0000 | [diff] [blame] | 1 | { pkgs, config, lib, ... }: { |
| 2 | systemd.user.services."clicks.codes" = { |
| 3 | Unit.Description = "Run clicks.codes"; |
| 4 | Install.WantedBy = [ "default.target" ]; |
| 5 | |
| 6 | Service.ExecStart = "${pkgs.nix}/bin/nix develop --command pnpm start"; |
| 7 | Service.WorkingDirectory = "${config.home.homeDirectory}/clicks.codes"; |
| 8 | Service.Environment = "PATH=${pkgs.git}/bin"; |
| 9 | }; |
Skyler Grey | 4d5e2f2 | 2023-12-23 00:12:20 +0000 | [diff] [blame^] | 10 | |
| 11 | systemd.user.services."signup.hopescaramels.com" = { |
| 12 | Unit.Description = "Run hopescaramels signup page"; |
| 13 | Install.WantedBy = [ "default.target" ]; |
| 14 | |
| 15 | Service.ExecStart = "${pkgs.nix}/bin/nix develop --command pnpm start"; |
| 16 | Service.WorkingDirectory = "${config.home.homeDirectory}/signup.hopescaramels.com"; |
| 17 | Service.Environment = "PATH=${pkgs.git}/bin"; |
| 18 | }; |
Skyler Grey | 52d38f1 | 2023-12-11 19:02:41 +0000 | [diff] [blame] | 19 | } |