blob: 33f8a49d87780006dd83c2955cc1d36fe3d9a981 [file] [log] [blame]
Skyler Grey8b4f7b62024-02-17 12:23:02 +00001{ config, pkgs, lib, ... }: {
2 systemd.services.jinx = { # running for Pinea
3 serviceConfig = {
4 User = "jinx";
5 ExecStart = "${pkgs.nix}/bin/nix develop --command pnpm start";
6 WorkingDirectory = "/services/jinx/Jinx";
7 LoadCredential = "postgres_password:${config.sops.secrets.clicks_jinx_db_password.path}";
8 Environment = [
9 "PATH=${pkgs.git}/bin"
10 "DATABASE_PASSWORD_FILE=%d/postgres_password"
11 ];
12 };
13 wantedBy = [ "default.target" ];
14 description = "Run Jinx";
15 };
16}