Skyler Grey | f08a619 | 2024-06-01 23:55:20 +0000 | [diff] [blame] | 1 | # SPDX-FileCopyrightText: 2024 Clicks Codes |
2 | # | ||||
3 | # SPDX-License-Identifier: GPL-3.0-only | ||||
4 | |||||
5 | { | ||||
6 | config, | ||||
7 | lib, | ||||
8 | pkgs, | ||||
9 | ... | ||||
10 | }: | ||||
11 | { | ||||
12 | options = { | ||||
13 | clicks.users.deployers = lib.mkOption { | ||||
14 | type = lib.types.listOf lib.types.str; | ||||
15 | default = [ ]; | ||||
16 | description = "Users who should be allowed to deploy to this server. They will be given passwordless access to run commands as root"; | ||||
17 | }; | ||||
18 | }; | ||||
19 | } |