Skyler Grey | 0e05d26 | 2023-10-09 07:04:36 +0000 | [diff] [blame] | 1 | { config, ... }: { |
| 2 | services.keycloak = { |
| 3 | enable = true; |
| 4 | settings = { |
| 5 | http-host = "127.0.0.1"; |
| 6 | http-port = 9083; |
| 7 | https-port = 9084; |
| 8 | http-enabled = true; |
| 9 | |
| 10 | proxy = "edge"; |
| 11 | |
| 12 | # https-port = 9084; |
| 13 | hostname = "login.clicks.codes"; |
| 14 | hostname-strict = false; |
| 15 | |
| 16 | https-certificate-file = "/var/keycloak/login.clicks.codes.rsa.cert.pem"; |
Skyler Grey | fe1740c | 2023-10-21 01:24:18 +0000 | [diff] [blame] | 17 | https-certificate-key-file = |
| 18 | "/var/keycloak/login.clicks.codes.rsa.private.pem"; |
Skyler Grey | 0e05d26 | 2023-10-09 07:04:36 +0000 | [diff] [blame] | 19 | }; |
| 20 | database = { |
| 21 | createLocally = false; |
| 22 | port = config.services.postgresql.port; |
| 23 | passwordFile = config.sops.secrets.clicks_keycloak_db_password.path; |
| 24 | }; |
| 25 | }; |
| 26 | } |