blob: 58371b1b2adfd582586c339c3540b4880386d805 [file] [log] [blame]
Skyler Greyf4d05f02024-06-06 21:25:39 +00001# SPDX-FileCopyrightText: 2024 Clicks Codes
2#
3# SPDX-License-Identifier: GPL-3.0-only
4
5{ lib, config, ... }:
6let
7 cfg = config.clicks.storage.raid;
8in
9{
10 options.clicks.storage.raid = {
11 enable = lib.mkEnableOption "Enable software raid with mdadm";
12 };
13
14 config = lib.mkIf cfg.enable { boot.swraid.enable = true; };
15}