Skyler Grey | f08a619 | 2024-06-01 23:55:20 +0000 | [diff] [blame] | 1 | # SPDX-FileCopyrightText: 2024 Auxolotl Infrastructure Contributors |
| 2 | # SPDX-FileCopyrightText: 2024 Clicks Codes |
| 3 | # |
| 4 | # SPDX-License-Identifier: GPL-3.0-only |
| 5 | |
| 6 | { pkgs, modulesPath, ... }: |
| 7 | { |
| 8 | boot.loader.systemd-boot.enable = true; |
| 9 | boot.loader.efi.canTouchEfiVariables = true; |
| 10 | |
| 11 | time.timeZone = "Etc/UTC"; |
| 12 | |
| 13 | environment.systemPackages = with pkgs; [ neovim ]; |
| 14 | |
| 15 | clicks = { |
| 16 | nix.enable = true; |
| 17 | |
| 18 | security = { |
| 19 | doas.enable = true; |
| 20 | |
| 21 | acme = { |
| 22 | enable = true; |
| 23 | email = "minion@clicks.codes"; |
| 24 | }; |
| 25 | }; |
| 26 | |
| 27 | services = { |
| 28 | ssh.enable = true; |
| 29 | }; |
| 30 | }; |
| 31 | |
| 32 | boot.initrd.availableKernelModules = [ |
| 33 | "nvme" |
| 34 | "xhci_pci" |
| 35 | "ahci" |
| 36 | "usbhid" |
| 37 | "uas" |
| 38 | "usb_storage" |
| 39 | "sd_mod" |
| 40 | ]; |
| 41 | boot.initrd.kernelModules = [ ]; |
| 42 | boot.kernelModules = [ "kvm-amd" ]; |
| 43 | boot.extraModulePackages = [ ]; |
| 44 | |
| 45 | fileSystems."/" = { |
| 46 | device = "/dev/disk/by-uuid/ab5c2f52-a737-4b29-a505-e3d0b9d0714c"; |
| 47 | fsType = "btrfs"; |
| 48 | options = [ "subvol=@" ]; |
| 49 | }; |
| 50 | |
| 51 | fileSystems."/boot" = { |
| 52 | device = "/dev/disk/by-uuid/880D-BBAB"; |
| 53 | fsType = "vfat"; |
| 54 | options = [ |
| 55 | "fmask=0022" |
| 56 | "dmask=0022" |
| 57 | ]; |
| 58 | }; |
| 59 | |
| 60 | swapDevices = [ ]; |
| 61 | |
| 62 | networking.useDHCP = true; |
| 63 | |
| 64 | system.stateVersion = "24.05"; |
| 65 | } |